1.1.3 Windows

Note: 以下の説明は、あなたがビルトイン LilyPad エディタを使用していると仮定しています。 より簡単な編集手段 で記述されているプログラムを使用している場合、ファイルのコンパイルで何か問題に遭遇した時はそのプログラムのドキュメントを調べてください。

ステップ 1. ‘.ly’ ファイルを作成する

デスクトップ上の LilyPond アイコンをクリックして、見本のファイルを開きます。

pictures/Learning_Win7_Welcome_File_Whole

見本ファイルの上端に表示されるメニューから ファイル > 名前を付けて保存 を選択します。ファイル > 上書き保存 を使用しないでください。なぜならファイルに有効な LilyPond ファイル名を付けるまで、上書き保存は機能しないからです。

pictures/Learning_Win7_Save_Menu

ファイル名を決めます。例えば ‘test.ly’ とします。

pictures/Learning_Win7_Save_File_With_Name

ステップ 2a. コンパイルする (ドラッグ&ドロップを使用します)

ファイルをコンパイルするには、好みで以下のいずれかの方法をとります:

ファイルを LilyPond アイコンに直接ドラッグ&ドロップします。

pictures/Learning_Win7_Open_Dragndrop

ファイルを右クリックして、ポップアップ メニューから プログラムから開く > LilyPond を選択します。 Right-click on the file and from the pop-up context menu choose

pictures/Learning_Win7_Open_Context_Menu

ステップ 2b. コンパイルする (ダブルクリックする)

あるいは、ただ単に ‘test.ly’ をダブルクリックします。

ステップ 3. 出力を閲覧する

test.ly’ をコンパイルしている間、コマンド ウィンドウが一瞬だけ開いて閉じます。この処理の間に 3 つのファイルが作成されます。

pictures/Learning_Win7_All_Files_Created

PDF ファイルは ‘test.ly’ ファイルの譜刻結果を保持しています。

pictures/Learning_Win7_Pdf_Output

その他のコマンド

新しくファイルを作成するには、以前に作成したファイルのウィンドウから ファイル > 新規作成 を選択します。

pictures/Learning_Win7_New_Menu

あるいは ファイル > 開く を選択し、以前に保存したファイルを開いて編集します。

pictures/Learning_Win7_Open_Menu

コンパイルを行う前にあなたが新たに行った編集を保存する必要があります。PDF ファイルが作成されない場合は、コンパイルの過程で作成されるログ ファイルでエラーをチェックしてください。

pictures/Learning_Win7_Log_File

このログ ファイルは、LilyPond ファイルをコンパイルする度に上書きされます。

PS ファイルは LilyPond が PDF ファイルを作成するために内部的に使用するもので、無視できます。PS ファイルもコンパイルの度に上書きされます。

PDF ファイルを PDF ビュー他で閲覧している場合、 新たにコンパイルを行う前に閉じる必要があります。なぜなら、閲覧されている間は新たに PDF ファイルを作成するのに失敗する可能性があるからです。


他の言語: English, česky, deutsch, español, français, magyar, italiano, nederlands
About automatic language selection.

LilyPond — 学習マニュアル