Windows

Note: LilyPond は テキスト ベース の楽譜作成プログラムです。グラフィカルな楽譜編集プログラムよりも、むしろプログラミング言語に似ています。LilyPond をダウンロードする前に、テキスト入力 を読んでください。

パッケージ

ダウンロード

インストール

  1. ダウンロードしたファイルをダブルクリックして、インストールを開始してください。インストーラの指示に従ってインストールしてください。すべてのインストール オプションにチェックを入れて、デフォルトのインストール場所にインストールすることをお勧めします。インストールが完了したら、‘Finish’ ボタンをクリックしてください。これで LilyPond はインストールされています。

アンインストール

アンインストールする方法は 2 つあります –

  1. スタート メニューから LilyPond を選択し、そこから “Uninstall” アイコンをクリックしてください。アンインストールが完了したら、‘Finish’ ボタンをクリックしてください。
  2. あるいは、コントロール パネルの “プログラムの追加と削除” を開き、LilyPond までスクロールして、“削除” ボタンをクリックしてください。

ファイルをコンパイルする

Note: 以下の説明は、あなたがビルトイン LilyPad エディタを使用していると仮定しています。 より簡単な編集手段 で記述されているプログラムを使用している場合、ファイルのコンパイルで何か問題に遭遇した時はそのプログラムのドキュメントを調べてください。

ステップ 1. ‘.ly’ ファイルを作成する

デスクトップ上の LilyPond アイコンをクリックして、見本のファイルを開きます。

pictures/Learning_Win7_Welcome_File_Whole

見本ファイルの上端に表示されるメニューから ファイル > 名前を付けて保存 を選択します。ファイル > 上書き保存 を使用しないでください。なぜならファイルに有効な LilyPond ファイル名を付けるまで、上書き保存は機能しないからです。

pictures/Learning_Win7_Save_Menu

ファイル名を決めます。例えば ‘test.ly’ とします。

pictures/Learning_Win7_Save_File_With_Name

ステップ 2a. コンパイルする (ドラッグ&ドロップを使用します)

ファイルをコンパイルするには、好みで以下のいずれかの方法をとります:

ファイルを LilyPond アイコンに直接ドラッグ&ドロップします。

pictures/Learning_Win7_Open_Dragndrop

ファイルを右クリックして、ポップアップ メニューから プログラムから開く > LilyPond を選択します。 Right-click on the file and from the pop-up context menu choose

pictures/Learning_Win7_Open_Context_Menu

ステップ 2b. コンパイルする (ダブルクリックする)

あるいは、ただ単に ‘test.ly’ をダブルクリックします。

ステップ 3. 出力を閲覧する

test.ly’ をコンパイルしている間、コマンド ウィンドウが一瞬だけ開いて閉じます。この処理の間に 3 つのファイルが作成されます。

pictures/Learning_Win7_All_Files_Created

PDF ファイルは ‘test.ly’ ファイルの譜刻結果を保持しています。

pictures/Learning_Win7_Pdf_Output

その他のコマンド

新しくファイルを作成するには、以前に作成したファイルのウィンドウから ファイル > 新規作成 を選択します。

pictures/Learning_Win7_New_Menu

あるいは ファイル > 開く を選択し、以前に保存したファイルを開いて編集します。

pictures/Learning_Win7_Open_Menu

コンパイルを行う前にあなたが新たに行った編集を保存する必要があります。PDF ファイルが作成されない場合は、コンパイルの過程で作成されるログ ファイルでエラーをチェックしてください。

pictures/Learning_Win7_Log_File

このログ ファイルは、LilyPond ファイルをコンパイルする度に上書きされます。

PS ファイルは LilyPond が PDF ファイルを作成するために内部的に使用するもので、無視できます。PS ファイルもコンパイルの度に上書きされます。

PDF ファイルを PDF ビュー他で閲覧している場合、 新たにコンパイルを行う前に閉じる必要があります。なぜなら、閲覧されている間は新たに PDF ファイルを作成するのに失敗する可能性があるからです。

コマンドラインから実行する

Note: GUI 環境の方を好むのであれば、以下の説明は無視してください。

Windows のコマンドライン

LilyPond を実行する最も簡便な方法は、LilyPond 実行可能のファイルを保持しているフォルダを、環境変数 “Path” に追加することです。

  1. コントロール パネルの “システム” を開き、“詳細設定” タブを選択し、“環境変数” ボタンをクリックします。
  2. “システム環境変数” リストから変数 “Path” を選択し、編集ボタンをクリックします。“システム変数の編集” というタイトルのウィンドウが表示されます。“変数値” の最後に、LilyPond の実行可能ファイルを保持しているフォルダを、以下のように付け加えます:
    [既存の Path];DIR\LilyPond\usr\bin
    

    Note: DIR は、一般には C:\Program Files です。

    “OK” ボタンをクリックしてウィンドウを閉じます。

個々の実行可能ファイルを呼び出す

lilypond, lilypond-book, convert-ly などの LilyPond 実行可能ファイルをコマンドラインから呼び出すことによって、実行することができます:

lilypond test.ly

法律用語


他の言語: English, česky, deutsch, español, français, magyar, italiano, nederlands, 中文
About automatic language selection.

Validation

lilypond.org をホスティングしてくれている webdev.nl に感謝します。 Valid HTML 4.01 Transitional