Développement

Développement pour LilyPond 2.19.14

Note : Il s’agit des versions instables et de développement. Si vous avez le moindre doute quant à l’utilisation ou l’installation de LilyPond, nous vous enjoignons à utiliser le téléchargement de la version stable et la lecture des manuels pour la version stable.

Numérotation des versions

Il existe deux jeux de version pour LilyPond : des versions stables et des versions instables de développement. Les versions stables comportent, en versionnage « mineur », un numéro pair (par ex. 2.8, 2.10 ou 2.12). Les versions de développement, quant à elles, comportent un versionnage « mineur » impair (par ex. 2.7, 2.9 ou 2.11).

Téléchargement

Des instructions concernant git et la compilation sont exposées dans le Guide du contributeur.

dépôt git de LilyPond

Les rédacteurs de la documentation ainsi que les testeurs préféreront travailler à partir des binaires les plus à jour :

GNU/Linux x86: LilyPond 2.19.14-1

GNU/Linux 64: LilyPond 2.19.14-1

GNU/Linux PPC: LilyPond 2.19.14-1

FreeBSD i386: LilyPond 2.19.14-1

FreeBSD amd64: LilyPond 2.19.14-1

MacOS X x86: LilyPond 2.19.14-1

MacOS X PPC: LilyPond 2.19.14-1

Windows: LilyPond 2.19.14-1

Source: lilypond-2.19.14.tar.gz

Le guide du contributeur

Le développement de LilyPond est relativement complexe. Dans l’espoir d’aider les nouveaux contributeurs, et dans le but de préserver au mieux la stabilité de ce système, nous avons rédigé un manuel dédié aux activités de développement.

Note : Dans la mesure où les développeurs de LilyPond sont disséminés sur la planète, il n’est pas prévu que ce document soit un jour traduit…

Tests de régression

Toutes versions

Manuels

Note : Il s’agit des manuels pour LilyPond 2.19.14 ; la dernière mouture est consultable sur http://lilypond.org


Autres langues : English, català, česky, deutsch, español, magyar, italiano, 日本語, nederlands, 中文.
About automatic language selection.

Validation

Remerciements à webdev.nl pour l'hébergement de lilypond.org. Valid HTML 4.01 Transitional